彩虹炒股分享网

rsi指标背离选股,RSI指标牛市背离

请高人设置一个rsi指标顶底背离及选股公式(说明RSI指标参数全部设定为9)。

看看

哪位大侠给下列KDJ MACD RSI三背离共振幅图做个选股公式(出现手指),谢谢!

把以上公式中的所有输出“:”后加一个“=”号,再在后面加一句
AG:MACD底背离 AND KDJ底背离 AND RSI底背离;
选股公式只能有一个输出,记住这点自己动手也不会很难的。
DIFZ:=EMA(C,12)-EMA(C,26);
DEAZ:=EMA(DIFZ,9);
MACDZ:=8*(DIFZ-DEAZ);
RSV:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*247.2-123.6;
SQX:=(C-MA(CLOSE,13))*10;
DIF:=EMA(MA(SQX,7),1);
DEA:=EMA(DIF,7);
MACD:=(DIF-DEA)*2;
K:=SMA(SMA( RSV,3,1),3,1),COLORWHITE;
D:=MA(EMA(K,3),3),COLORYELLOW;
J:=3*K-2*D,COLORMAGENTA;
A11:=BARSLAST(REF(CROSS(DIF,DEA),1));
B1:=REF(C,A11+1)>C AND REF(DIF,A11+1)<DIF AND CROSS(DIF,DEA);
A12:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
B2:=REF(C,A12+1)>C AND REF("KDJ.K",A12+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");
A13:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
B3:=REF(C,A13+1)>C AND REF("RSI.RSI1",A13+1)<"RSI.RSI1"AND CROSS("RSI.RSI1","RSI.RSI2");
C1:=BARSLAST(REF(CROSS(DEA,DIF),1));
D1:=REF(C,C1+1)<C AND REF(DIF,C1+1)>DIF AND CROSS(DEA,DIF);
C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K",C2+1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K");
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)>"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");
MACD底背:=IF(B1>0,50,0),LINICK2,COLORRED;
KDJ底背:=IF(B2>0,65,0),LINICK2,COLORFF00FF;
RSI底背:=IF(B3>0,80,0),LINICK2,COLORYELLOW;
MACD顶背:=IF(D1>0,-50,0),LINICK2,COLOR00FF00;
KDJ顶背:=IF(D2>0,-65,0),LINICK2,COLORFFCC66;
RSI顶背:=IF(D3>0,-80,0),LINICK2,COLORWHITE;
AG:MACD底背 AND KDJ底背 AND RSI底背;

求Rsi指标与股价底顶背离指标,无未来。

LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));
B3:REF(C,A3+1)>C AND REF(RSI1,A3+1)<RSI1 AND CROSS(RSI1,RSI2);
DRAWTEXT(B3>0,0.4,'R底'),COLOR0000FF;
C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));
D3:REF(C,C3+1)<C AND REF(RSI1,C3+1)>RSI1 AND CROSS(RSI2,RSI1);
DRAWTEXT(D3>0,0.9,'R顶'),COLORFF9900;

rsi顶底背离选股公式请高手制作 通信达软件的 每一个大小顶底的波段背离都选出来只要过去式就可以了

LC:=REF(CLOSE,1);
A:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
底背离:C<=LLV(C,60) AND A>LLV(A,60) AND A>=REF(A,1);
上面这个是底背离的,下面的是顶背离的:
LC:=REF(CLOSE,1);
A:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
顶背离:C>=LLV(C,60) AND A<LLV(A,60) AND A<=REF(A,1);

求助,在通达信里面用RSI选股的公式

1、通过公式选出RSI数值小于20的个股;或者选出RSI大于80的个股
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),20,1)/SMA(ABS(CLOSE-LC),20,1)*100;
XC20:=RSI<=20 ;
XC80:=RSI>80;
XG:XC20 OR XC80;

2、选股时,可分别选不同的K线周期:30分钟,60分钟,日线,周线。

3、打开预警开关,可在日线图能做到即时弹窗提醒。

请高人设置一个rsi指标顶底背离及选股公式(说明RSI指标参数全部设定为9)。

看看